Start a new topic

Installing the recommended version of Monetdb on Ubuntu 20.04/20.10

A necessary step of installing Omniscope on Ubuntu is the installation of Monetdb.  The recommended version of Monetdb is 11.29.7 which is no longer available in repositories of newer version of Ubuntu. 


It is still possible to install Monetdb 11.29.7 on Ubuntu 20.04/20.10:


- Stop any instances of Omniscope Evo that might be running on the system

- Make sure there are no instances of the process mserver5 running on the system

- Remove any repositories referring to Monetdb: you can do this via the Software Sources  application or by editing the file /etc/apt/sources.list.d

- uninstall the existing version of Monetdb if any via  sudo apt purge monetdb5-server

Delete Omniscope db farm in ~/.visokioappdata/Visokio/Omniscope/MonetDb 

- Import GPG key via wget --output-document=- https://www.monetdb.org/downloads/MonetDB-GPG-KEY | sudo apt-key add -

- Add the monetdb repository for older version of ubuntu:  sudo apt-add-repository "deb http://dev.monetdb.org/downloads/deb/ bionic monetdb"

Install the recommended version of Monetdb via sudo apt update && sudo apt install monetdb5-server=11.29.7



 Next time Omniscope is started it will use the recommended version of the data engine.

Login or Signup to post a comment